TESIS: Member of the Vector Group
Virtual Test Driving

Contact @ Vector

TESIS is now part of Vector
Web www.vector.com/dyna4
Phone +49 89 747377-0
Send an email message

Support for DYNA4, veDYNA and enDYNA

Support Contact

Support @ Vector >>

Licensing and compatibility for DYNA4

Since December 2019, starting with Release 4.0,  DYNA4 is licensed via Vector. Learn more >>

Compatibility Overview for DYNA4 3.0, 3.1 and 4.0 available in Vector KnowledgeBase

R3.6 with veDYNA 3.13 & enDYNA 2.3 compatibility

  
 Operating SystemsSupport
 Windows 64 bit 
 Windows 10 
 Windows 8.1 
 Windows 7 
 Matlab / Simulink 
 64 bit versions1) 
 Matlab 9.7 (R2019b)2) 
 Matlab 9.6 (R2019a)2) 
 Matlab 9.5 (R2018b) 
 Matlab 9.4 (R2018a) 
 Matlab 9.3 (R2017b) 
 Matlab 9.2 (R2017a) 
 Matlab 9.1 (R2016b) 
 Matlab 9.0 (R2016a) 
 Matlab 8.6 (R2015b) 
 32 bit versions3) 
 Matlab 8.6 (R2015b) 
 Real-time platforms 
 dSpace4) DS1006 and Scalexio 
 dSpace R2019-B 
 dSpace R2019-A 
 dSpace R2018-B 
 dSpace R2018-A 
 dSpace R2017-B 
 dSpace R2017-A 
 dSpace R2016-B 
 dSpace R2016-A 
 National Instruments5) 
 NI VeriStand 2019 
 NI VeriStand 2018 
 NI VeriStand 2017 
 ETAS 
 ETAS Labcar-Operator 5.4.9 
 MathWorks5) 
 Simulink Real-Time 2015a 
 Opal-RT 
 Opal-RT RT-Lab 11 

Annotations

1) For Matlab 64bit: RSim and Simulink Rapid Accelerator target build requires Microsoft Visual C/C++ Compiler (e.g. by installing the free Windows SDK v7.1, ask our support for instructions)
2) The “Pass MATLAB Workspace to RTW Executable” feature for veDYNA is not supported in Matlab R2019a and Matlab R2019b
 
3) For Matlab 32bit: On Windows 7 64bit, installing the official Microsoft Windows Hotfix KB2588507 is strongly recommended to avoid problems with node-locked licensing mechanism
4) dSpace XiL API has to be installed and a XiL API license must be available
5) Only in combination with Microsoft Visual C/C++ Compiler (e.g. by installing the free Windows SDK v7.1, ask our support for instructions)


Licensing for veDYNA and enDYNA

Licensing

Licensing veDYNA and enDYNA requires a MAC address (not necessary for dongle or floating licenses). To get the MAC address, run the tool getmacaddress.exe on the workstation on which the TESIS software is to be installed. The tool will detect the Ethernet MAC address. If several network cards are installed, several MAC addresses will be displayed.

Expired License

Your software license has expired or you want to make some changes?

Extend your license >>

Changing a licensed MAC address

Every installation-related license can be transferred to different hardware or to a different platform during the license period provided that these are supported by the licensed version. The licensee will then receive a new license key for the new hardware identification (Host ID, CPU ID or MAC address). To change the license, you will require the following document:

Declaration of License Transfer >>

 

Compatibility of previous versions

R3.5 with veDYNA 3.12 & enDYNA 2.2 compatibility

  
 Operating SystemsSupport
 Windows 64 bit 
 Windows 10 
 Windows 8.1 
 Windows 7 
 Matlab / Simulink 
 64 bit versions 1) 
 Matlab 9.5 (R2018b) 
 Matlab 9.4 (R2018a) 
 Matlab 9.3 (R2017b) 
 Matlab 9.2 (R2017a) 
 Matlab 9.1 (R2016b) 
 Matlab 9.0 (R2016a) 
 Matlab 8.6 (R2015b) 
 32 bit versions 2) 
 Matlab 8.6 (R2015b) 
 Real-time platforms 
 dSpace3) DS 1005, DS1006 and Scalexio 
 dSpace R2018-A 
 dSpace R2017-B 
 dSpace R2017-A 
 dSpace R2016-B 
 dSpace R2016-A 
 National Instruments 4) 
 NI VeriStand 2018 
 NI VeriStand 2017 
 ETAS 
 ETAS Labcar-Operator 5.4.4 
 MathWorks 4) 
 Simulink Real-Time 2015a 
 Opal-RT 
 Opal-RT RT-Lab 11 

Annotations

1) For Matlab 64bit: RSim and Simulink Rapid Accelerator target build requires Microsoft Visual C/C++ Compiler (e.g. by installing the free Windows SDK v7.1, ask our support for instructions)
2)
For Matlab 32bit: On Windows 7 64bit, installing the official Microsoft Windows Hotfix KB2588507 is strongly recommended to avoid problems with node-locked licensing mechanism
3) dSpace XiL API has to be installed and a XiL API license must be available
4) Only in combination with Microsoft Visual C/C++ Compiler (e.g. by installing the free Windows SDK v7.1, ask our support for instructions)


R3.4 with veDYNA 3.11 & enDYNA 2.1 compatibility

  
 Operating SystemsSupport
 Windows 64 bit 
 Windows 10 
 Windows 8.1 
 Windows 7 
 Windows 32 bit 
 Windows 8.1 
 Windows 7 
 Matlab / Simulink 
 64 bit versions 1) 
 Matlab 9.2 (R2017a) 
 Matlab 9.1 (R2016b) 
 Matlab 9.0 (R2016a) 
 Matlab 8.6 (R2015b) 
 Matlab 8.5 (R2015a) 
 32 bit versions 2) 
 Matlab 8.6 (R2015b) 
 Matlab 8.5 (R2015a) 
 Real-time platforms 
 dSpace3) DS 1005, DS1006 and Scalexio 
 dSpace R2017-A 
 dSpace R2016-B 
 dSpace R2016-A 
 dSpace R2015-B 
 dSpace R2015-A 
 National Instruments 4) 
 NI VeriStand 2016 
 NI VeriStand 2015 SP1 
 ETAS 
 ETAS Labcar-Operator 5.4.4 
 ETAS Labcar-Operator 5.3 
 MathWorks 4) 
 Simulink Real-Time 2015a 
 Opal-RT 
 Opal-RT RT-Lab 11 

 

Annotations

1) For Matlab 32bit: On Windows 7 64bit, installing the official Microsoft Windows Hotfix KB2588507 is strongly recommended to avoid problems with node-locked licensing mechanism
2) For Matlab 64bit: RSim and Simulink Rapid Accelerator target build requires Microsoft Visual C/C++ Compiler (e.g. by installing the free Windows SDK v7.1, ask our support for instructions)
3) dSpace XiL API has to be installed and a XiL API license must be available
4) Only in combination with Microsoft Visual C/C++ Compiler (e.g. by installing the free Windows SDK v7.1, ask our support for instructions)


DYNA4 2.8 hardware & software compatibility

  
 Operating SystemsSupport
 Windows 
 Windows 10, 64 bit 
 Windows 7, 64 bit 
 Matlab / Simulink 
 64 bit versions 1) 
 Matlab 9.3 (R2017b) 
 Matlab 9.2 (R2017a) 
 Matlab 9.1 (R2016b) 
 Matlab 9.0 (R2016a) 
 Matlab 8.6 (R2015b) 
 Matlab 8.5 (R2015a) 3) 
 Matlab 8.5 (R2014b) 3) 
 32 bit versions 2) 
 Matlab 8.6 (R2015b) 
 Matlab 8.5 (R2015a) 3) 
 Matlab 8.4 (R2014b) 3) 
 Real-time platforms 
 dSpace4), 5) DS 1005, DS1006, DS1007 and Scalexio 
 dSpace R2017-A 
 dSpace R2016-B 
 dSpace R2016-A 4) 
 dSpace R2015-B 4) 
 dSpace R2015-A 4) 
 National Instruments 6) 
 NI VeriStand 2017 
 NI VeriStand 2016 
 NI VeriStand 2015 SP1 
 NI VeriStand 2015 
 Vector Informatik 6) 
 CANoe 10.0 7) 
 CANoe 9.0 8) 
 ETAS 
 ETAS Labcar-Operator 5.4.4 
 ETAS Labcar-Operator 5.4.3 
 ADTF 
 ADTF 2.x win64_vc100 5) 
 Assystem (Berner & Mattner) 
 Modular HiL / Messina 
 MicroNova 
 NovaCarts 
 MathWorks 6) 
 Simulink Real-Time 
 Opal-RT 
 Opal-RT RT-Lab 
 Concurrent 
 Simulation Workbench 

 

Annotations

1) For Matlab 64bit: RSim and Simulink Rapid Accelerator target build requires Microsoft Visual C/C++ Compiler (e.g. by installing the free Windows SDK v7.1, ask our support for instructions)
2) For Matlab 32bit: On Windows 7 64bit, installing the official Microsoft Windows Hotfix KB2588507 is strongly recommended to avoid problems with node-locked licensing mechanism

3) Matlab versions not supported in DYNA4 Driver Assistance package
4) dSpace XiL API has to be installed
5) DYNAanimation 2.x not compatible with 64bit dSPACE releases, use DYNAanimation 3 instead
6) Only in combination with Microsoft Visual C/C++ Compiler (e.g. by installing the free Windows SDK v7.1, ask our support for instructions)
7) Vector add-on Matlab Interface V4.2.4 required
8) Vector add-on Matlab Interface V3.2.3 required